Forum

[Lightburn] CNC 301...
 
Notifications
Tout effacer

[Lightburn] CNC 3018 : prise de tete pour le deplacement de la tete

Benitos Prod.
(@benitos-prod)
Messages: 10
Membre éminent
Lanceur de sujet
 

hello,

j'ai installe lightburn et j'essaye de faire des gravure avec ma CNCpro 3018.

mais lorsque j'essaye de deplacer la tete laser avec les touches correspondante , ca ne fait jamais ce que je veux.

le reglage de ma CNC semble correcte car j'ai deja fait des gravure avec laser GRBL et des usinages CNC avec des projets fait sous fusion 360.

j'ai mis des switch pour avoir le homing .

quand je lance mon homing la tete va se placer au fond a gauche comme prevu par mon homing.

dans lightburn je demande "obtenir la position" dans l'onglet "deplacer" : position x=0 y=0 z=0

jusque la tout va bien ensuite je veux deplacer la tete avec les fleches dans l'onglet "deplacer" et la j'ai n'importe quoi

exemple : je veux juste deplace en X et les 2 axes X et Y bouge ou message d'erreur :

console : ci dessous

G21 G54

G91

G1 X20 Y1 F501 S1

G90

M2

ALARM:2

La cible de mouvement de g-code dépasse la course de la machine. Position de la machine conservée en toute sécurité. L'alarme peut être déverrouillée. (Cliquez avec le bouton droit sur le bouton 'Appareils' pour réinitialiser la connexion)

En ligne ou quasi en ligne 2 :

Flux terminé en 0 :00

 

je precise j'ai juste appuye sur la fleche gauche , donc pourquoi j'ai du Y ?

 

une idee

 

 

 
Posté : 10 mars 2023 20:02
Ben Maker
(@benmaker)
Messages: 356
Admin
 

Bonjour,
Qu'il y ai du Y en utilisant les flèches en X ça me parait étrange si tout fonctionne sur les autres logiciels.
Dans Lightburn le point zéro est bien configuré en haut a gauche?
Ça expliquerai qu'il parte dans la mauvaise direction, dépasse les limites et qu'il t'affiche directement X0 Y0 Z0 lors du homing.

Lightburn utilise des coordonnées inversées.
De base il devrait t'indiquer les infos entrées dans les paramètres $130 et $131 (distance de déplacement maximale) ici, X300 Y180.
Soit X-298 Y-178 Z-2 (a peu près, ça dépend des dimensions que tu as entré, moins la distance de retrait du homing $27, ici 2mm)
Il faut ensuite entrer la commande suivante pour inverser la direction :
G10 L2 P1 X-298 Y-178 Z0 (remplace les infos du X et Y par tes infos de paramètre $130 et $131)
Le mieux étant de l'enregistrer comme macro pour la refaire a chaque démarrage.
Avec cette commande, Lightburn indique X0 Y0 Z0
Normalement c'est tout ce qu'il y a faire.

Tu peux aussi faire un point 0 avec G92 X0 Y0 Z0 si tu ne veux pas t'embêter avec le homing.

 
Posté : 10 mars 2023 22:37
Benitos Prod.
(@benitos-prod)
Messages: 10
Membre éminent
Lanceur de sujet
 

j'ai deja fait ce que tu dis mais ca change pas .

en $130 et $131 j'ai les valeurs de la cnc cad 300mm et 180mm

en $27 = 2 pour 2mm pour mon homing avec retrait de 2mm.

de mon cote ce n'est pas normal d'avoir du deplacement Y alors que j'en demande pas et la ca n'as rien a voir avec les coordonnées de la tete

je vais continuer a chercher mais .....

 
Posté : 11 mars 2023 10:52
Ben Maker
(@benmaker)
Messages: 356
Admin
 

Dans les autres logiciels ton point d'origine était aussi a l'arrière gauche et les axes se déplaçaient dans le bon sens ?

Pour le déplacement en Y lors du déplacement en X... je n'ai jamais eu le cas, j'y réfléchis, mais c'est étrange. ^^

 
Posté : 11 mars 2023 14:59
Benitos Prod.
(@benitos-prod)
Messages: 10
Membre éminent
Lanceur de sujet
 

bon j'avance

j'ai installé une version cracké de lightburn 1.3.04 parce que a l'epoque j'ai pas eu le temps de tester pendant les 30 jours gratuit. et maintenant il me dit que j'ai depasse les 30 jours mais je voudrais bien re-essayer ce logiciel donc j'ai trouver cette solution.

avec cette version 1.3.01 , j'ai ce probleme de deplacement de Y alors que pas demandé.

j'ai donc pris une ancienne version (toujours cracke pour la meme raison) et avec la version 1.2.04 j'ai plus ce probleme de deplacement de Y non voulu.

donc un point de resolu .....

mais avec cette version j'ai une invertion de l'axe. je ne sais pas dire lequel car lightburn n'a pas l'air d'avoir un choix top concernant les deplacements.

dans la fenetre deplacement on peut choisir l'option "atteindre" en rentrant directement les coordonnéees X et Y .

je pars de ma position Homing au fond a gauche avec une position lu par lightburn de x=0 y=0 z=0.

si je choisit "atteindre" x=100 et Y=0 , la tete part a droite de 100mm = tout est ok

si je choisit x=0 et Y=50, j'ai un message d'erreur a cause d'une valeur Y le homing est en butée. Mais il est impossible de rentrer une valeur negative de Y pour faire venir la tete vers moi .

Donc faire bouger la tete en Y avec le bouton "atteindre" c'est impossible.

sinon j'ai essaye de modifier le point de depart pour faire une gravure .

Mais mon texte gravé est a l'envers sur un seule Axe. axe Y

cad que les texte se lit bien de gauche a droite mais le haut et le bas son inverse

 

 

 
Posté : 11 mars 2023 16:02
Ben Maker
(@benmaker)
Messages: 356
Admin
 

Ok, quand on pirate des logiciels faut s'attendre a des bugs étranges...
Donc l'axe Y est inversé. il faut changer le paramètre $3 pour ça.
Il faudra peut-être jouer aussi avec le paramètre $23, vu que ton homing se fait en négatif pour le Y.
Il y a des tableaux sur cette page pour t'aider a trouver le bon réglage : Configuration de GRBL v1.1

 
Posté : 11 mars 2023 17:24
Benitos Prod.
(@benitos-prod)
Messages: 10
Membre éminent
Lanceur de sujet
 

j'ai changé ma position de Homing en devant a gauche comme beaucoup mais ca change rien.

dans candle je suis bien pour les deplacements

cad : X+ ma tete va a gauche , Y+ ma tete va au fond  ( cad plateau avance devant donc )

dans lightburn ( effectivement la version cracké a peut etre des problemes mais commente je peux re tester sans payer ? )

je vais donc essayé d'inverser l'axe Y dans la console pour voir

 
Posté : 12 mars 2023 13:52
Benitos Prod.
(@benitos-prod)
Messages: 10
Membre éminent
Lanceur de sujet
 

Bon j'ai fini par acheter la version de lightburn . j'ai fait disparaitre les bug que j'avais . donc mefiance avec la version cracké . mais bonne nouvelle vous pouvez prolonger la version de 30 jours si vous en faite la demande sur le site.

sinon pour etre dans les clous avec les deplacements de lightburn , j'ai ete obligé de changer mon code GRBL de la console.

donc position de homing obligatoire a l'avant gauche. c'est moins pratique pour positionner les pieces mais bon .......

 

voici :

$$

$0=10

$1=25

$2=0

$3=6

$4=0

$5=0

$6=0

$10=1

$11=0.500

$12=0.002

$13=0

$20=1

$21=1

$22=1

$23=3

$24=25.000

$25=500.000

$26=250

$27=2.000

$30=1000

$31=0

$32=1

$100=795.070

$101=796.020

$102=797.340

$110=800.000

$111=800.000

$112=300.000

$120=20.000

$121=20.000

$122=20.000

$130=300.000

$131=180.000

$132=50.000

ok

 

 

 
Posté : 2 avril 2023 11:19
Ben Maker
(@benmaker)
Messages: 356
Admin
 

Et ben parfait. Comme quoi il vaut mieux acheter le logiciel, En plus il vaut le coup ! 😉
Ça ne m'a pas trop dérangé le homing a l'avant gauche sur 3018. Ça reste comme pour l'usinage et c'est pas plus mal quand on échange souvent le laser et la broche, ce qui était mon cas.
Il est surement possible de passer a l'arrière gauche avec $23 et en modifiant les coordonnées des codes que j'ai fourni dans l'article pour inverser l'axe Y.

 
Posté : 2 avril 2023 13:30
Benitos Prod.
(@benitos-prod)
Messages: 10
Membre éminent
Lanceur de sujet
 

concernant le homing : c'est plus pratique pour moi de le mettre au fond a gauche pour bien pouvoir fixer la piece sur le plateau sans avoir la tete

mais avec lightburn , c'est pas terrible car apres la CNC travaille avec des coordonnées negatif et ca fou le bordel.

mais je vais laisser le homing devant a gauche.

 

sinon je confirme , lightburn vaut vraiment le coup pour du gravage laser

 
Posté : 6 avril 2023 18:02
Ben Maker
(@benmaker)
Messages: 356
Admin
 

Oui c'est plus compliqué avec Lightburn sur cnc.
Au pire, fait une macro pour déplacer la tête de 180mm afin de fixer tes pièces. 😉

 
Posté : 6 avril 2023 20:45

NAVIGATION