Création d’un spoilboard en MDF pour la CNC 3018 Pro

On se retrouve pour la création du spoilboard ou planche martyre pour la CNC 3018 (ou plutôt sa version xl en 3040). Une amélioration très utile pour ne pas abimer le plateau alu et pour gagner en précision lors des gravures.

Création d'un spoilboard pour la CNC 3018

liens affiliés

Le but premier d’un spoilboard est de protéger le plateau alu de la CNC en ajoutant une planche martyre sous la pièce a usiner. Il peut aussi servir a niveler le plateau, qui sur ces petites machines chinoises est presque impossible a mettre droit. Pour faire ça il faut le surfacer avec une fraise de gros diamètre. Dans cette vidéo, je vous montre toutes les étapes pour faire un spoilboard pour la CNC 3018 Pro vous même, de la prise de côtes au surfaçage. Bonne vidéo !

Cette section contient des liens d’affiliation. C’est totalement gratuit pour vous et ça permet de faire vivre le site lorsque vous réalisez un achat en passant par eux.

Matériel

CNC 3018 Pro, Kit d’extension de l’axe Y, Kit d’extension du plateau, Interrupteurs fin de course, Z-probe
Fraise a surfacer, Fraise droite 3.175mm

Matériaux

Medium 10mm, Vis M5 15mm à tête plate et T-nuts

Logiciels

Carbide create v6, GRBL Candle

cnc 3018 - création d'un spoilboard
cnc 3018 - création d'un spoilboard

Le spoilboard, une partie qu’on néglige souvent mais qui est quand même importante.
Avoir un support droit permet d’améliorer grandement la qualité de la gravure.
Fini les parties mal gravées ou pas entièrement découpées !

Commentaires

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Pour continuer a répondre a une discussion, cliquez sur répondre sur le premier message.

18 réponses

  1. Avatar de Sylvain

    Bonjour,
    J’ai résolu mes problèmes.
    Par rapport à la carte d’origine (WOODPECKER V3.4) je confirme que les polarités de la barette de connexion des end-stops est inversée.
    J’ai donc dû refaire le câblage des end-stops.
    Comme je l’expliquais dans un précédent message, je voulais ajouter une manivelle, que j’ai dessiné et imprimé, sur les axes X et Y, mais le décalage la vis sans fin de l’axe Y dans le coupleur, a pour effet de diminuer la course du plateau, et donc ne permet plus à la came de venir appuyer sur le switch de fin de course.
    J’ai donc supprimé la manivelle et remis l’ensemble comme à l’origine.
    Il serait toujours possible de déplacer le switch, mais on perd déjà un peu de longueur avec la rallonge du plateau, je ne voulais pas en perdre plus.
    Je pense que les machines qui sont équipées nativement de la manivelle doivent avoir une vis sans fin plus longue.
    Maintenant, le homming fonctionne.
    Encore merci d’avoir pris du temps pour m’aider.

  2. Avatar de Sylvain

    Pour l’axe Y, je crois avoir trouvé.
    Ma machine n’étant pas équipée nativement des boutons moletés sur les différents axes, j’ai reculé la vis sans fin du Y en la décalant au niveau du coupleur du moteur pour ajouter une manivelle me permettent de déplacer le plateau manuellement.
    Et maintenant, détail que je n’ai pas vu avant, la came du Y du plateau ne va plus toucher la lame du switch.
    J’ai effectué un test pendant le homming en appuyant sur le contact et il a fonctionné.
    Il me reste donc plus qu’à déplacersoit la vis sans fin, soit le switch. Mon souci devrait être résolu.
    A suivre

    1. Avatar de Ben Maker

      Ah oui si l’interrupteur n’est pas actionné, ça ne risque pas de marcher ^^

  3. Avatar de Sylvain

    Bonjour,
    Depuis hier, j’ai un petit peu avancé dans la mesure où, j’ai inversé les axes X et Z sur la carte mère. A partir de là le homming commence normalement, càd que le Z en premier, le X en second et lors du contact avec le switch du Y le moteur ne s’arrête pas et les voyants led des switches sont toujours éteints.
    Donc homming incomplet.
    En comparant les deux cartes, sérigraphie et voltmètre à l’appui, je me suis aperçu que les rangées de pins sur lequelles on branche les switches ont les polarités inversées.
    Sur la carte d’origine (WOODPECKER V 3.4) la masse (GND) se trouve sur les pins inférieurs et sur la nouvelle, elle se trouve sur le pins supérieurs.
    J’ai donc inversé la connexion du +5v, mais en allumant la carte via l’interrupteur général, le moteur de la broche est parti à fond.
    Je ne comprends plus.

    1. Avatar de Ben Maker

      C’est uniquement la sérigraphie des emplacements des pins pour les switch X et Z qui sont inversés sur la woodpecker 3.4.
      Si ta carte a en plus une inversion des + et -, ça commence a devenir compliqué ^^
      Mais ça peut expliquer pourquoi les leds ne s’allument pas si elles sont raccordées au GND plutôt qu’au +5v.
      Si le Z et le X fonctionnent, il y a du progrès. Pour le Y tu dois avoir un soucis de branchement quelque part (câbles inversé, abimé, mauvais contact…), il se câble comme le X.
      Essaye sans les leds pour commencer, quand ça marchera il n’y aura plus qu’a les brancher au +5v (si elles n’ont pas cramé… ça aime pas trop être branché a l’envers ces bêtes la.)

  4. Avatar de Sylvain

    Merci beaucoup pour les infos.
    Effectivement, je me souviens, maintenant, que lorsque j’ai installé les interrupteurs de fin de course, il y a trois ans, j’avais vu que, page 8 – § « 2.2.1.4 Câblage » du pdf « Réussir vos fraisages avec la CNC 3018 Pro ! » de CNC Fraises il est écrit :
    « Attention : si votre machine est équipée de la carte « WOODPECKER CNC CAMXTOOL V3.4″,il y a une erreur de sérigraphie : le home switch de l’axe « Z »doit être branché sur la position « X » et le home switch de l’axe « X » doit être branché sur la position « Z . »
    C’est le cas de ma carte d’origine, et j’ai donc appliqué cette recommandation qui a très bien fonctionné depuis.
    Il est donc possible que sur la nouvelle carte, les sérigraphies aient pu être corrigées. Je vais donc explorer cette possibilité et je te tiens informé.
    Mon petit souci pourra peut-être aider une autre personne.
    Parmi mes recherches, et en attendant de trouver la solution à mon problème, j’ai rebranché l’ancienne carte pour être sûr que mes connexions sont bonnes.
    Eh bien, miracle, bien que le MOSFET ait fumé, le moteur de broche tourne et tout fonctionne comme avant. Je n’avais pas osé le faire de peur de griller autre chose.
    En revanche, je vous pouvoir faire fonctionner la nouvelle, dont le ventilateur est beaucoup plus silencieux et qui possède un branchement natif pour l’arrêt d’urgence.
    Je tenais à te remercier au passage pour te excellents tuto sur les différents sujets, ils sont précis, concis et très agréables à regarder et à écouter.

  5. Avatar de Sylvain

    Bonjour,
    merci pour tes réponses. En fait je me suis mal exprimé avec cette phrase :
    « Concernant les pins de connexion des end stops, ils sont au nombre de deux pour chaque axe, y a t-il un côté (D ou G) à privilégier ou ça n’a pas d’importance ? »
    Je n’ai installé qu’un seul interrupteur par axe, comme tu le dis, ça suffit amplement.
    Je voulais dire que sur la carte mère il y a deux connecteurs par sortie (2 en X, 2 en Y et 2 en Z) et je voulais savoir s’il y a une importance de brancher à droite ou à gauche le connecteur pour chaque interrupteur ou sont-il en parallèle ?
    Je pense que si la config est bonne et que tout fonctionnait avant, c’est la carte qui a un problème (matériel ou firmware).
    J’ai deux nouvelles questions :
    – Aurais-tu éventuellement de la documentation sur cette carte, ou un lien pour en obtenir ?
    – Peut-on mettre à jour le firmware de cette carte (Je ne sais même pas qu’elle est sa version) ?
    Je te remercie par avance.

    1. Avatar de Ben Maker

      Ok, je pense que ça ne change rien qu’il soient sur les pins de gauche ou de droite, il doivent être reliés. Si les câbles sont sur le + et le – de la même ligne ça devrait fonctionner.
      La version de GRBL s’affiche dans la console de GRBL Candle lors de la connection, sur Amazon ils indiquent GRBL 1.1f donc ça ne doit pas venir de la, mais il doit être possible de flasher le firmware.
      Je me demande si ce ne serait pas une carte dérivée de la woodpecker 3.4 qui a les pins X et Z inversés il me semble. Ce qui fait que les inters marchent mais le homing ne comprend pas ce qui se passe.

  6. Avatar de Sylvain

    Bonjour et merci beaucoup pour ton retour rapide.
    Ma nouvelle carte est celle-ci :
    https://www.amazon.fr/dp/B08B654TVW?psc=1&ref=ppx_yo2ov_dt_b_product_details
    Voici mes paramètres GRBL qui fonctionnaient parfaitement sur l’ancienne carte :
    $$ < $0=10
    $1=25
    $2=0
    $3=2
    $4=0
    $5=0
    $6=0
    $10=1
    $11=0.010
    $12=0.002
    $13=0
    $20=0
    $21=1
    $22=1
    $23=3
    $24=25.000
    $25=500.000
    $26=250
    $27=2.000
    $30=1000
    $31=0
    $32=0
    $100=800.000
    $101=800.000
    $102=800.000
    $110=1000.000
    $111=1000.000
    $112=600.000
    $120=30.000
    $121=30.000
    $122=30.000
    $130=300.000
    $131=330.000
    $132=45.000
    ok

    Concernant les pins de connexion des end stops, ils sont au nombre de deux pour chaque axe, y a t-il un côté (D ou G) à privilégier ou ça n'a pas d'importance ?
    J'ai monté les end stops que tu utilises dans ton tuto. Avec l'ancienne carte, la LED rouge s'allumait au moment du contact, avec la nouvelle, pas d'allumage.
    Encore merci pour ton aide

    1. Avatar de Ben Maker

      Bonjour, 2 interrupteurs par axe je trouve que ce n’est pas très utile, un par axe c’est suffisant pour le homing.
      Si tu as peur de dépasser de l’autre coté, ajoute des limites logicielles ($20 pour activer et $130 a $132 pour la distance max).
      Au niveau des paramètres ça a l’air ok.
      Essaye en ne gardant qu’un interrupteur par axe pour voir si ça marche, ça peut venir de parasites (certaines cartes sont plus sensibles).

  7. Avatar de Sylvain

    bonjour,
    merci beaucoup pour le retour. Je vais re-créer un nouveau chemin.

    Désolé de ne pas avoir répondu plus tôt, mais j’ai eu un souci avec machine.
    Un morceau de MDF s’est coincé entre le sabot d’aspiration et la broche, ce qu’il l’a bloqué.
    Le Mosfet a fumé et j’ai dû changer la carte mère.
    Après avoir remplacé les valeurs dans la console avec celles de l’ancienne carte, le homing ne fonctionne pas.
    Les contacts de fin de course sont inefficaces lord du homing, alors qu’ils stoppent les moteurs si on les sollicite manuellement
    durant un déplacement.
    Je ne comprends pas quel est le problème.
    Y a t-il une solution ?

    1. Avatar de Ben Maker

      Bonjour, pas de bol, heureusement ces cartes ne sont pas trop chères.
      Tu as remplacé par quel modèle de carte ? Tu peux poster tes paramètres GRBl ?

  8. Avatar de Sylvain

    Bonjour,
    après avoir suivi votre excellent tutoriel sur CARBIDE CREATE, logiciel que j’utilise maintenant, j’ai réalisé un spoilboard pour ma 3018 pro.
    Je l’ai réalisé d’une façon différente pour maintenier les pièces à usiner avec des cames.
    Je voulais éviter que la broche rencontre les brides par inadvertance.
    Je suis arrivé à l’étape du surfaçage en suivant votre tuto, mais je n’arrive pas à obtenir le même parcours d’outil que le votre, càd en suivant
    les lignes. le mien est complètement désordonné et demande un travail de 24 mn.
    Quelle est la solution pour remédier à ce problème ?
    Par avance, merci.

    1. Avatar de Ben Maker

      Bonjour, l’intégralité du parcours est constitué d’une seule ligne en zigzag pour que la fraise suive la ligne du début à la fin.
      Si la ligne est en plusieurs parties, il est possible que le logiciel n’usine pas dans l’ordre souhaité.

  9. Avatar de olivier

    bonjour, s’il te reste des petites lignes c’est que tu travailles un coup en avalant et un coup en opposition. Normalement avec ta fraise tu dois tourner dans le sens horaire . quand tu attaque le bois, il doit s’opposer au sens de rotation. c’est à dire que si tu commence l’usinage en bas tu dois faire que des passes de gauche à droite . ou solution spirale de l’extérieur vers le centre dans le sens horaire. quand tu te sers d’une défonceuse surtout à la volée c’est très important sinon c’est dangereux. les forces appliquées au moteur ne sont pas les mêmes . en règle général pour la sécurité et un bon fraisage il faut toujours travailler en opposition. même sur une fraiseuse manuelle, j’ai appris ça à l’école il y a 35ans. j’ai vu une fraise de 150mm casser à cause de ça et trop de profondeur de passe. Sinon bons tutos.

    1. Avatar de olivier

      Modification, normalement avec une cnc il faut travailler en avalant si il y a un système automatique du rattrapage du jeu : le deuxième écrou avec le ressort. Mais je ne suis pas persuadé que sur une 3018 le reste soit assez rigide pour supporter les changements d’efforts. je pense que justement les petites différences de niveau sont dû à ça. Désolé mais j’étais resté sur les fraiseuses manuelles et le travail du bois ou cela est toujours d’actualité

  10. Avatar de Didier R

    bonjour Ben
    pour changer la hauteur du portique je me suis servi des 2 profiles de la 3018 que j’ai fixe par dessus qui me donne 3 réglages de hauteur
    merci pour tes vidéos tres utiles

  11. Avatar de Dravo

    Bravo , c’est fait utile et sans prétention, très agréable à suivre , merci Ben